[ < ] [ > ]   [ << ] [ 上へ ] [ >> ]         [トップ] [目次] [インデックス] [ ? ]

1.1 ファイルをコンパイルする

@translationof Compiling a file

このセクションでは “コンパイル”—出力ファイルを作り出すために (あなたが記述した) LilyPond 入力ファイルを処理すること—について説明します。


[ < ] [ > ]   [ << ] [ 上へ ] [ >> ]         [トップ] [目次] [インデックス] [ ? ]

1.1.1 入力を作成する

@translationof Entering input

“コンパイル” は LilyPond フォーマットで書かれた入力ファイルから出力ファイルを作り出す処理を意味する用語です。出力ファイルには一般に PDF (印刷や閲覧用)、MIDI (演奏用)、それに PNG (オンラインで使用)があります。LilyPond 入力ファイルはシンプルなテキストファイルです。

最初の例ではシンプルな入力ファイルを示します。

 
\version "2.21.3"
{
  c' e' g' e'
}

出力は以下のようになります:

[image of music]

Note: LilyPond 入力の音符と歌詞は、 { 波括弧 } で囲まれている必要があります。さらに、あいまいさを避けるために、波括弧は行の最初か最後でない限りはスペースによって囲まれているべきです。波括弧はこのマニュアルのいくつかの例では省略されているかもしれませんが、あなた自身が作成する楽譜では忘れないでください!マニュアルの中にある例を表示する方法についての更なる情報については、このマニュアルの読み方 を参照してください。

さらに、LilyPond 入力は大文字/小文字の区別 があります。{ c d e } は有効な入力ですが、{ C D E } はエラーになります。



[ < ] [ > ]   [ << ] [ 上へ ] [ >> ]         [トップ] [目次] [インデックス] [ ? ]

出力を作り出す

@translationof Producing output

出力を作り出す方法はあなたが使用している OS とプログラムに依存します。

LilyPond 用のサポートを有するテキストエディタが他にもいくつかあります。更なる情報は、 (web)より簡単な編集手段 section ‘より簡単な編集手段’ in General Information を参照してください。

Note: あなたが初めて LilyPond を実行した場合、1, 2 分かかるかもしれません。なぜなら、まず最初にすべてのシステム フォントが分析されるからです。それから後は、LilyPond はずっと早く実行されます!


[ < ] [ > ]   [ << ] [ 上へ ] [ >> ]         [トップ] [目次] [インデックス] [ ? ]

1.1.2 MacOS X

@translationof MacOS X

Note: 以下の説明は、あなたが LilyPond アプリケーションを使用していると仮定しています。 (web)より簡単な編集手段 section ‘より簡単な編集手段’ in General Information で記述されているプログラムを使用している場合、ファイルのコンパイルで何か問題に遭遇した時はそのプログラムのドキュメントを調べてください。

ステップ 1. ‘.ly’ ファイルを作成する

LilyPond.app をダブルクリックして、見本のファイルを開きます。

pictures/Learning_Macos_welcome

画面の左上に表示されているメニューから File > Save を選択します。

pictures/Learning_Macos_Save_menu

ファイル名を決めます。例えば ‘test.ly’ とします。

pictures/Learning_Macos_Save_file_with_name

ステップ 2. コンパイルする (LilyPad を使用します)

同じメニューから Compile > Typeset を選択します。

pictures/Learning_Macos_Typeset_menu

新たにウィンドウが開き、先ほど保存したファイルのコンパイル進捗ログを表示します。

pictures/Learning_Macos_Compiling_log

ステップ 3. 出力を閲覧する

コンパイルが終了すると、元のファイルと同じ名前の PDF ファイルが作成され、自動的にデフォルトの PDF ビューアで表示されます。

pictures/Learning_Macos_pdf_output

その他のコマンド

LilyPond 用に新しくファイルを作成するには、File > New を選択します。

pictures/Learning_Macos_New_menu

あるいは、File > Open を選択し、既存のファイルを開いて編集します。

pictures/Learning_Macos_Open_menu

Compile > Typeset を行う前にあなたが新たに行った編集を保存する必要があります。PDF ファイルが表示されない場合は、進捗ログのウィンドウでエラーをチェックしてください。

Mac OS に付属されているデフォルトの Preview PDF ビューアを使用していない場合、以前のコンパイルで生成された PDF ファイルを開いていると、その後に実行するコンパイルは更新された PDF を生成するのに失敗する可能性があります。その時は、元の PDF ファイルを閉じてください。


[ < ] [ > ]   [ << ] [ 上へ ] [ >> ]         [トップ] [目次] [インデックス] [ ? ]

1.1.3 Windows

@translationof Windows

Note: 以下の説明は、あなたがビルトイン LilyPad エディタを使用していると仮定しています。 (web)より簡単な編集手段 section ‘より簡単な編集手段’ in General Information で記述されているプログラムを使用している場合、ファイルのコンパイルで何か問題に遭遇した時はそのプログラムのドキュメントを調べてください。

ステップ 1. ‘.ly’ ファイルを作成する

デスクトップ上の LilyPond アイコンをクリックして、見本のファイルを開きます。

pictures/LilyPad

見本ファイルの上端に表示されるメニューから ファイル > 名前を付けて保存 を選択します。ファイル > 保存 を使用しないでください。なぜならファイルに有効な LilyPond ファイル名を付けるまで、上書き保存は機能しないからです。

pictures/FileSave

ファイル名を決めます。例えば ‘test.ly’ とします。

pictures/SaveAs

ステップ 2. コンパイルする

LilyPond ファイルを楽譜にするためには、コンパイルする必要があります。これにはいくつかの方法があります。 – ドラッグ&ドロップ、右クリック、ダブルクリック、コマンドライン(コマンドプロンプト)です。最初の 3 種類を見てみましょう。

1. ファイルを LilyPond アイコンに直接ドラッグ&ドロップします。

pictures/DragDrop

何も起こらないように見えますが、しばらくすると、デスクトップに 2 つの新しいファイル – ‘test.log’ と ‘test.pdf’ – が表示されるはずです。

2. ファイルを右クリックして、ポップアップ メニューから Generate PDF を選択します。

pictures/GenPDF

3. あるいは、ただ単に ‘test.ly’ をダブルクリックします。

ステップ 3. 出力を閲覧する

‘test.pdf’ は ‘test.ly’ ファイルの譜刻結果を保持しています。ダブルクリックすると、PDF ビュアーで開かれます。

pictures/PDFRead

その他のコマンド

新しくファイルを作成するには、以前に作成したファイルのウィンドウから ファイル > 新規作成 を選択します。あるいは ファイル > 開く を選択し、以前に保存したファイルを開いて編集します。または、ファイルを右クリックして Edit Source を選択しても、編集することができます。

pictures/EditFile

コンパイルを行う前にあなたが新たに行った編集を保存する必要があります。PDF ファイルが作成されない場合は、コンパイルの過程で作成されるログ ファイルでエラーをチェックしてください。

pictures/BadLog

このログ ファイルは、LilyPond ファイルをコンパイルする度に上書きされます。

PDF ファイルを PDF ビュアーで閲覧している場合、 新たにコンパイルを行う前に閉じる必要があります。なぜなら、閲覧されている間は新たに PDF ファイルを作成するのに失敗する可能性があるからです。

pictures/BadLog2
[ < ] [ > ]   [ << ] [ 上へ ] [ >> ]         [トップ] [目次] [インデックス] [ ? ]

1.1.4 コマンド ライン

@translationof Command-line

Note: 以下の説明は、あなたがコマンドライン プログラムに慣れていると仮定しています。 (web)より簡単な編集手段 section ‘より簡単な編集手段’ in General Information で記述されているプログラムを使用している場合、ファイルのコンパイルで何か問題に遭遇した時はそのプログラムのドキュメントを調べてください。

ステップ 1. ‘.ly’ ファイルを作成する

‘test.ly’ というテキスト ファイルを作成し、以下を記述します:

 
\version "2.20.0"
{
  c' e' g' e'
}

ステップ 2. コンパイルする (コマンドラインで)

‘test.ly’ を処理するには、コマンド プロンプトに以下を打ち込みます:

 
lilypond test.ly

以下のようなものが表示されます:

 
GNU LilyPond 2.20.0
Processing `test.ly'
Parsing...
Interpreting music...
Preprocessing graphical objects...
Solving 1 page-breaking chunks...[1: 1 pages]
Drawing systems...
Layout output to `test.ps'...
Converting to `./test.pdf'...
Success: compilation successfully completed

ステップ 3. 出力を閲覧する

結果として得られる ‘test.pdf’ を閲覧したり、印刷したりすることができます。


[ < ] [ > ]   [ << ] [ 上へ ] [ >> ]

This document was generated by gub on 7 月 13, 2020 using texi2html 1.82.

他の言語: English, català, česky, deutsch, español, français, magyar, italiano, nederlands
About automatic language selection.